Afbeeldingen niet zichtbaar

Ik heb eerst een website aangemaakt in een testomgeving.
Nadien overgezet naar het juiste domein (andere hosting): www.verheyen-koen.be

Als werkt zoals het zou moeten, behalve mijn afbeeldingen zijn niet zichtbaar.

Weet er iemand een oplossing? Wat deed ik verkeerd of zie ik nog over het hoofd?

Auteur: 
Nieka
afbeelding van joker
Door joker op 6 november, 2017 - 09:29

De eerste afbeelding op de homepage verwijst naar http://www.verheyen-koen.be/sites/default/files/pictures/pv%20en%20personeel%20012.JPG. Je moet mss eens kijken via ftp of die afbeelding daar effectief staat.

groet
Joker

Door Nieka op 6 november, 2017 - 09:42

Daar staan ze inderdaad. Dat was eerst de fout, maar nu heb ik de afbeeldingen in de juiste map geplaatst en de juiste link naar de afbeeldingen gelegd (of dat zou toch zo moeten zijn)

afbeelding van be-web
Door be-web op 6 november, 2017 - 13:23

Heb je het .htaccess bestand in de map /sites/default/files ook overgezet? Ik vermoed dat daar een fout in zit. Op het bestand krijg ik een server fout 500.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door Nieka op 8 november, 2017 - 08:03

Het zou best kunnen dat hier de fout inzit maar ik krijg dit niet overgezet. Heb al geprobeerd het bestand te vervangen maar dit lukt niet, dan heb ik de code willen overschrijven maar ook dit wordt niet aanvaard....

afbeelding van be-web
Door be-web op 8 november, 2017 - 08:53

Je kunt de .htaccess in /sites/default/files weghalen. Drupal maakt deze zelf weer aan met standaard instellingen. Als deze niet worden geaccepteerd, dan botst er iets met de serverinstellingen. Hoeft geen probleem te zijn, meestal is een kleine wijziging in jouw .htaccess bestand voldoende. Anders contact opnemen met hostingbedrijf.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door Nieka op 8 november, 2017 - 08:56

Thanks, het zal dan dat laatste worden, want ik kan het bestand niet verwijderen.

Door Nieka op 8 november, 2017 - 09:16

Gelukt, bedankt Hans!

afbeelding van jo.w
Door jo.w op 8 november, 2017 - 10:38

Ik zie nog steeds geen afbeeldingen.

Jo

Door Nieka op 8 november, 2017 - 10:55

Je hebt gelijk. Op mijn pc wel (google Chrome) maar op mijn laptop niet (ook Chrome).
Wat is dan dit weer?

afbeelding van be-web
Door be-web op 8 november, 2017 - 11:25

Mogelijk zag je ze wel toen de .htaccess was verwijderd. Zodra deze opnieuw wordt aangemaakt gaat het mis. Ik gok op een conflict met serverinstellingen.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

afbeelding van be-web
Door be-web op 8 november, 2017 - 11:26

Zet er eens een leeg .htaccess bestand in. Dan maakt Drupal er zelf geen aan.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door Nieka op 8 november, 2017 - 13:15

Dat heb ik net gedaan en nu krijg ik de afbeeldingen te zien op alle schermen en verschillende browers, dus ik denk dat het geholpen heeft

afbeelding van be-web
Door be-web op 8 november, 2017 - 13:48

Mooi. Maar nog wel even uitzoeken welke regel in de .htaccess het probleem veroorzaakt. Je hebt namelijk wel een potentieel veiligheidsrisico.

Bekijk de inhoud van een standaard .htaccess bestand die in /sites/default/files wordt gezet. Mogelijk werkt het al goed als je alleen het bovenste blokje weghaald/uitzet, dus de regels die beginnen met 'Options'.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.