Het geselecteerde bestand kon niet gekopiëerd worden omdat er geen bestand met deze naam bestaat. Controleer dat u de juiste be

Na het upgraden naar de nieuwste versie van Drupal 6.16 krijg ik de volgende melding:
"Het geselecteerde bestand kon niet gekopiëerd worden omdat er geen bestand met deze naam bestaat. Controleer dat u de juiste bestandsnaam opgegeven heeft. "

Statusrapportage meldt dat: "Status HTTP-aanvraag is mislukt"

Voorts is de site nu ineens zo snel als dikke str..............

Iemand een idee wat hier aan de hand is?

Auteur: 
PageMaker
Door PageMaker op 5 mei, 2010 - 16:01

Recente logs geeft nog de volgende informatie:
Type: Lokalisatie
Bericht: Er is een fout opgetreden bij het aanmaken van het bestand met Javascript-vertalingen voor de taal Nederlands.

Misschien kan iemand zeggen waar ik nu verder moet zoeken zoals:
Waar staat: "het bestand met Javascript-vertalingen voor de taal Nederlands."
Hoe heet: "het bestand met Javascript-vertalingen voor de taal Nederlands."

Wanneer dat ontbreekt waar kan ik het ophalen?

Oorzaak? Nederlandse versie Drupal 6.16 op drupal.be onvolledig?

Door PageMaker op 5 mei, 2010 - 17:37

Betreft: "Status HTTP-aanvraag is mislukt"

is opgelost.

Download en installeer/activeer de module op: http://drupal.org/project/http_request_fail_reset

run cron

et voila, de melding verdwijnt! lees goed de "caveat emptor" heel belangrijk!!!

Door PageMaker op 5 mei, 2010 - 20:07

Na enig zoeken stel ik vast dat na een volledig nieuwe installatie het volgende pad leeg is:

.../sites/default/files/languages/

in eerdere versies staat daar een js bestand. (En kopiëren uit een andere site werkt niet)

Toch iets mis met de download op drupal.be?

Graag een reactie

afbeelding van hansrossel
Door hansrossel op 5 mei, 2010 - 21:26

Niets mis met de download op drupal.be maar met de instellingen van jouw server. Ik heb het net voor alle zekerheid eens getest, en alles ok. Er moet inderdaad na installatie een nl_...js bestand in default/files/languages zitten en dat is ook zo. Als dat niet zo is bij jouw betekent dit gewoon dat je site geen schrijfrechten heeft. Zet de rechten voor files op 777.

Je zegt het trouwens zelf: "kopiëren uit een andere site werkt niet", dus geen schrijfrechten op de map.

Hans
KOBA

Door mad972.nl op 5 mei, 2010 - 21:11

Nee dan is er iets mis, met de rechten op je map sites.
Dat probleem hebben wij ook, omdat we geen rechten kunnen toevoegen aan deze map.
In dat geval kunnen er geen temp of java bestanden upgeload worden in deze map.
Dan hou je deze melding.

Wij waren uiteindelijk dat roze blok zat van de meldingen elke keer.
Deze optie kun je uitzetten binnen je php bestand in je template file...

Door PageMaker op 5 mei, 2010 - 22:54

Dank voor de reacties.
1.
Hans je zegt: "Je zegt het trouwens zelf: "kopiëren uit een andere site werkt niet", dus geen schrijfrechten op de map."
Dat is een beetje vreemd want het is een localhost installatie en het kopiëren lukt in de verkenner uitstekend. Ik heb nl_....js vanuit een andere installatie die geen probleem geeft gekopieerd, maar dat werkt niet.
2.
mad972: "Deze optie kun je uitzetten binnen je php bestand in je template file..."
Dat is ongetwijfeld waar, maar zeg ook even Hoe dat moet; welk php bestand en wat moet ik doen.
Graag een reactie

Door mad972.nl op 5 mei, 2010 - 23:23

2. Dat is vrij makkelijk:

Je gaat naar: themes -> jouw ingestelde template -> page.tpl

En wist dit gewoon, en slaat het bestand weer op en load het up naar je server.

<?php if ($show_messages && $messages): print $messages; endif; ?>
<?php print $help; ?>

<?php print $content ?>

Let wel! In dat geval komt er ook geen één melding meer tevoorschijn. Enkel als voorbeeld, verkeerde inlog/wachtwoord etc, word het veld rood omlijnt.
Dan weet je dat er wat mis is...
Maar van dat andere gezeur ben je af, en de site draait er niet minder om eerlijk gezegd.

Snap, überhaubt nog steeds niet waarvoor dat gekopieer nodig is eigenlijk....Zal vast een functie hebben.
Stuit er helaas telkens op eerlijk gezegd zodra ik een Drupal site op een server zet, en waarvan de server niet genoeg rechten beschikbaar stelt.

Sucses!

Door PageMaker op 5 mei, 2010 - 23:29

Dank je, het is inderdaad een "houtje touwtje" oplossing; maar vooralsnog kan ik er mee leven.

Een en ander neemt niet weg dat het downloaden vanaf de drupal.be site in het recente verleden geheel geen probleem opleverde en nu ineens wel. De laatste goed werkende versie dateert van 28-4-2010 11:05 en daarna ontbrak het nl_.......js bestand met als gevolg de gewraakte meldingen.

Door mad972.nl op 5 mei, 2010 - 23:41

Klopt inderdaad!

Zat er in het begin gigantisch mee te knoeien, terwijl alles op localhost feiloos werkt.
Probleematiek zit em vaak in diverse Hosting servers waar je gewoonweg geen toestemming krijgt/niet aanwezig is kwa mogelijkheid om rechten te geven aan je map.

Als je uiteindelijk gaat Goochelen naar: '' Het geselecteerde bestand kon niet gekopiëerd worden '', dan kom je wel zo ontzettend veel antwoorden tegen.
Maar een enkel antwoord is telkens, ''Je rechten moet je aanpassen in de map''.
Ja, als dat nu niet kan of mogelijk is, dan word het lastig.

Bij deze dan uiteindelijk een zogenaamd ''houtje Touwtje'' oplossing zoals je het zelf zo mooi noemt....

Door PageMaker op 6 mei, 2010 - 11:48

Ik blijf het vreemd vinden.
1.
De "houtje touwtje" oplossing is een uitstekende tussenstap om de ellende weg te krijgen, maar het logbestand blijft natuurlijk wel vollopen met die vervelende meldingen. Een meer permanente structurele oplossing blijft geboden.
2.
Ik merk op dat installaties met de nieuwste download vanaf drupal.be op een XP-machine in een usbwebserver gewoon prima werken. Maar op een Win7-machine schrijft ie het bestand .../sites/default/files/languages/nl_hexadeeciebeesie.js niet weg. Daar dus toch iets met rechten??
3.
Ook een eerst onder XP geïnstalleerde drupal-site en daarna gekopieerd naar een W7-machine draait in de usbwebserver vrolijk verder. Dus: als nl_hexadeeciebeesie.js eenmaal in de site zit dan gaat het wel gewoon verder. Maar rechtstreeks onder W7 lijkt het niet te willen.

O ja, die usbwebserver staat gewoon op de HDD.
4.
Zoals ik al zei: het overnemen van het nl_hexadeeciebeesie.js bestand naar een andere site werkt niet. hexadeeciebeesie lijkt op een soort site-unieke code; waar dat bij een vertaling voor nodig zou zijn ontgaat me.
5.
Voor de volledigheid. De gewraakte ellende treedt alleen op wanneer ik met admin aanlog.

Door mad972.nl op 6 mei, 2010 - 12:00

Ook bij punt 1 valt wat te doen natuurlijk.
Was het vergeten te melden, maar de simpele oplossing is om in het Prestatie menu bij Site Instellingen, de Minimum cache-levensduur gewoonweg op 1 minuut zetten.
Dan wist ie alle rommel na 1 minuut, en de site loopt als een trein dan!

Zelf hebben wij het beheer gedeelte in een andere template content staan.
Zo zien we wel de meldingen in dat geval.

Bij ons zijn dat deze meldingen:

Het geselecteerde bestand C:\Temp\fil1C7E.tmp kon niet upgeload worden omdat de doelmap niet correct ingesteld is.
Het geselecteerde bestand C:\Temp\fil1C7F.tmp kon niet upgeload worden omdat de doelmap niet correct ingesteld is.
Het geselecteerde bestand C:\Temp\fil1C80.tmp kon niet upgeload worden omdat de doelmap niet correct ingesteld is.

afbeelding van hansrossel
Door hansrossel op 6 mei, 2010 - 12:29

Gewoonweg alle meldingen uitschakelen lijkt mij geen goede oplossing.

Op een hosting kun je normaal gezien als je via ftp connecteert (met filezilla, dreamweaver, ...) gewoon rechtermuisknop doen bij de remote files op het mapje en dan zie je onderaan permissies waar je die kunt aanpassen. Op localhost moet je met de rechtermuisknop op een map de permissies kunnen goedzetten. Met command line kun je "chmod -R 777 files" doen op het files mapje en indien nodig "chown example.example files" om de user example (de website dus) eigenaar te maken van de map.

Op windows 7 heb ik ook het http request status probleem met wamp. Wellicht heeft http://blog.teliaz.com/?p=449 er iets mee te maken. Ik heb het niet geprobeerd op te lossen. Het probleem ligt hoogstwaarschijnlijk tussen een of ander compatibiliteitsprobleem tussen Windows7 en Apache of WAMP, dus geen probleem van Drupal. Een dual boot met Ubuntu/Windows is heel snel geinstalleerd en Drupal werkt gewoon tien keer sneller op Ubuntu dan Windows. Het is een klein beetje werk maar op lange termijn ga je dat zeker niet beklagen, snel werken is toch wel belangrijk en een van de redenen waarom je op localhost werkt.

Hans
KOBA

Door PageMaker op 6 mei, 2010 - 16:00

Hans,
Je zegt: "Met command line kun je "chmod -R 777 files" doen op het files mapje en indien nodig "chown example.example files" om de user example (de website dus) eigenaar te maken van de map."
Op een localhost met XAMPP zal dat wel gaan, maar ik nog niet hoe dat met de usbwebserver zou moeten.

Die http.sys had ik al gekilled omdat die poort 80 inpikt die Apache nodig heeft; ook de errortype had ik al aangepast.

Behalve eerst op een XP-machine installeren ben ik nu echt out-off-options.

Wat is trouwens Ubuntu, kun je dat eten?

afbeelding van hansrossel
Door hansrossel op 6 mei, 2010 - 16:46

Ubuntu is een van de meest toegankelijke distributies van Linux en wellicht de makkelijkste als je van Windows komt. Je kunt ze downloaden op http://www.ubuntu.com/GetUbuntu/download en indien gewenst eerst eens vanop cd bekijken zonder dat er iets op je pc geinstalleerd wordt. Eenmaal overtuigd kun je voor de installatie gaan, je harde schijf verdelen onder Ubuntu en windows en een dual boot maken, waarbij je bij het opstarten telkens kunt kiezen tussen windows of Ubuntu.

Hans
KOBA

Door PageMaker op 9 mei, 2010 - 15:31

Zoekt en VINDT!!
http://blog.psicomante.net/node/221 geeft een module die juist het hier gesignaleerde probleem oplost door het her-opbouwen van het js vertaalbestand.
Installeer de module, activeer en leeg de cache; et voila die vervelende melding is weg!

Door PageMaker op 11 mei, 2010 - 12:49

Ik zei:
http://blog.psicomante.net/node/221 geeft een module die juist het hier gesignaleerde probleem oplost door het her-opbouwen van het js vertaalbestand.
Maar ook dat blijkt niet te werken.

Installatie onder XAMPP levert - behalve de melding: HTTP-aanvraag mislukt - geen problemen op. Het bestand: nl_ hexadeesiebeesie.js staat er gewoon te staan.

Door skrebbel op 21 november, 2010 - 10:20

Hoi allemaal,

Ik had hetzelfde probleem en van alles geprobeerd, op mijn lokale installatie in een WAMP (UwAmp). Uiteindelijk bleek het echter door iets heel anders te komen dan wat hierboven (of op veel andere sites) genoemd werd: de "tijdelijke map" (temporary files directory) stond op "C:\Windows\TEMP", en die is in Windows 7 niet publiek lees- of schrijfbaar.

Dit kun je veranderen onder Site-instellingen|Bestandssysteem. Dat de temp-map niet goed was wordt bovenaan die pagina gemeld met (nog) een foutmelding, bovenop de "Het geselecteerde bestand kan niet worden..." foutmelding die je op elke pagina ziet.

Ik heb gewoon een lege map c:\temp aangemaakt en de setting daarnaar veranderd. Toen was de bovengenoemde melding weg, en de "Het geselecteerde bestand kan..." ineens ook, op alle pagina's!

Wellicht is dit bij meer mensen het probleem.

(Drupal 6.19, Windows 7 64 bit, UwAmp)

Door evdebo op 25 november, 2010 - 14:13

Bedankt! De tijdelijke map aanpassen blijkt inderdaad de sleutel tot de oplossing (in mijn geval een map binnen de site).
(Drupal 6.19, Windows 7 32-b, Usb Webserver).

afbeelding van koentimmers
Door koentimmers op 10 april, 2011 - 11:49

Ik wil hier toch vlug iets aan toevoegen: ik heb de foutmelding ook gekregen en de fout zit hem bij de instellingen van bestandssysteem (admin/settings/file-system). Kies best voor Privé, met "sites/default/files/tmp" bij tijdelijke map.
Afhankelijk van de server moet je ook nog rechten toekennen op deze map.
Wanneer je in files geen taalbestand hebt, dan komt dat ook door te weinig rechten. Wanneer je bv op eigen computer werkt, dan moet je soms je server opstarten via Rechtermuisknop (opstarten als administrator). Zoniet wordt bij installatie van Drupal geen taalbestand in de map geplaatst. Je kan dit niet meer oplossen. Het taalbestand bij een andere drupalsite kopiëren, lukt NIET. De bestandsnaam is uniek. Succes!
Koen Timmers - zelfstudie.be

afbeelding van hansrossel
Door hansrossel op 11 april, 2011 - 09:27

Ik zou in Drupal 6 nooit voor het privé bestandssysteem kiezen en altijd publiek nemen. Prive betekent dat voor alle bestanden eerst gecontroleerd wordt als je die mag zien. Dit kan de bedoeling zijn als je beveiligde bestanden hebt, bijvoorbeeld foto's die je verkoopt of documenten in Organische groepen die niet mogen gezien worden. Maar het heeft ook tot gevolg dat bij gewone foto's op een pagina ook telkens de permissies worden gecontroleerd wat bijvoorbeeld bij een pagina met 10 foto's een enorm performantieprobleem oplevert. In Drupal 7 werd dit opgelost en kun je per bijlageveld kiezen als het prive of publiek is. Voor Drupal 6 zou ik aanraden om nooit het prive bestandssysteem te gebruiken. Als je te beveiligen bestanden hebt kun je in Drupal 6 via een kleine aanpassing in .htaccess (http://drupal.org/node/540754) toch de instelling op "publiek" houden en enkel de te beveiligen mappen op privé zetten.
Je hebt ook problemen als je de instelling van prive achteraf weer aanpast naar publiek of omgekeerd.

Voor tijdelijke map kies je om veiligheidsredenen best een tmp map die buiten het publieke deel van je hostingaccount zit, dus /tmp waarbij tmp dus op hetzelfde niveau zit als public_html of www of htdocs.

Hans
KOBA

afbeelding van koentimmers
Door koentimmers op 11 april, 2011 - 09:33

Ok, bedankt voor de tip!
Kent iemand toevallig ook de code waarmee je via .htaccess de schone urls kan forceren? Voor op servers als one.com waar clean urls niet mogelijk zijn?

afbeelding van hansrossel
Door hansrossel op 11 april, 2011 - 09:34

als je zoekt op one.com en htaccess ga je het hier op het forum wel ergens vinden, komt er gewoon op neer dat je een # (comment maken) moet zetten voor twee van de bovenste instellingen (options en nog één)

Hans
KOBA

afbeelding van koentimmers
Door koentimmers op 11 april, 2011 - 09:37

ja, die regels zijn me bekend. Anders krijg je drupal zelfs niet geïnstalleerd op hun servers...

# Don't show directory listings for URLs which map to a directory.
Options -Indexes
# Follow symbolic links in this directory.
Options +FollowSymLinks

Maar bij mijn weten staan ze los van de schone urls. Kent u deze regels waarmee de clean urls geactiveerd kunnen worden?

afbeelding van hansrossel
Door hansrossel op 11 april, 2011 - 09:42

Ik gebruik zelf geen one.com maar misschien kan dit je helpen http://joachimwillems.be/node/37

Hans
KOBA

afbeelding van koentimmers
Door koentimmers op 11 april, 2011 - 09:46

Lol, hij heeft zelf precies wat problemen... ;-) http://joachimwillems.be/node/37

afbeelding van hansrossel
Door hansrossel op 11 april, 2011 - 09:48

:) ja dat is waar, hij heeft ze blijkbaar toch nog niet in orde gekregen

Hans
KOBA

afbeelding van koentimmers
Door koentimmers op 11 april, 2011 - 09:53

One.com beweert dat dit kan, tot mijn verbazing. Ze geven een guide. Deze kan voor iedereen interessant zijn. Ik vond m alleszins niet via google. De dt-fouten zijn van de operator... ;-)

ja ziet u hiervoor de volgende guide
Site/map beveiligen:
Via onderstaande link vindt u een wizard voor het aanmaken van .htaccess voor het beveiligen van een site/map
http://one-docs.com/tools/htaccess/
Deze wizard maakt de inhoud voor uw .htaccess en .htpasswd aan.
U kunt deze inhoud opslaan als htaccess.txt en htpasswd.txt, dan uploaden naar de website, en dan hernoemen naar .htaccess en .htpasswd
-----------
Error pagina's:
Voegt u de volgende zin toe in het .htaccess bestand:
ErrorDocument 404 http://www.domain.com/lostpage.html
Vervang simpelweg 'domain.com'met uw eigen domeinnaam en 'lostpage.html'met de foutmelding -pagina welke u wilt gebruiken. Voor 500 error pagina's, vervang de '404'met een nieuw nummer voor de foutmelding.
----------
Ondersteund:
- Website/mappen met wachtwoord beveiligen
- IP-adressen blokkeren
- Aangepaste Error Pages (404, 301, 302, 500, 501 etc.)
- Bescherming tegen 'hotlinking
'- mod_rewrite (b.v. Zoekmachine-vriendelijke URL's)
- Geladen modules: mod_access, mod_auth, mod_auth_login, mod_dir, mod_expires, mod_headers, mod_includes, mod_mime_magic, mod_rewrite, mod_setenvif, mod_ssi
Niet ondersteund, alles wat begint met:
- Options
- php_value
- php_flag
- ForceType
- AddHandler
- SetHandler
----------
Voor verdere technische info kunt u hier kijken:
http://httpd.apache.org/docs/2.2/howto/htaccess.html
http://www.javascriptkit.com/howto/htaccess.shtml

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee