link met mysql database

Hallo,

ik ben bezig aan een tweede site maar de Mysql link lukt niet (ik heb er niet genoeg verstand van).

De volledige drupal kern staat in een submapje van de site www.xxxxxxxxx.be/drupal
Nu moet ik de link maken de database. Ik heb de code in de default.settings.php aangepast maar het werkt niet, ik krijg steeds die foutcode "niet gelukt verbinding te maken met ..."

Wat is nu de correcte code van onderstaande? Werkt localhost altijd of moet je een IP intikken als je dat hebt?

$db_url = 'mysql://naam:wachtwoord@localhost/databasenaam';
$db_url = 'mysql://naam:wachtwoord@localhost/drupal/databasenaam';
$db_url = 'mysql://naam:wachtwoord@123.456.789.123/databasenaam';
$db_url = 'mysql://naam:wachtwoord@123.456.789.123/drupal/databasenaam';

Ik zou graag eens een paar uurtjes bijles hebben van iemand (tegen betaling) om mij wat wegwijs te maken met deze .php codes en aanpassen van een .htaccess en zo. Liefst iemand omgeving Brugge.

alvast bedankt

Bram

Auteur: 
bramp
afbeelding van Bart Haedens
Door Bart Haedens op 21 juni, 2008 - 18:45

De goede is:

$db_url = 'mysql://naam:wachtwoord@localhost/databasenaam';

Localhost werkt in 99% van de gevallen.

Bart

Bart Haedens

Door bramp op 21 juni, 2008 - 19:30

Ik heb dit gewijzigd maar geraak nog niet verder, daarom deze vraag:

kan ik ook zonder Drupal testen als mijn gebruiksernaam en wachtwoord en database werken? Kan ik deze database op de één of andere manier aanspreken. Dan ben ik zeker dat er geen fout zit in de namen of het wachtwoord en dat de database actief is.

edit: Ik vond dit op een ander forum:

mysql -p -u the-database-username the-database-name

ik zou dit ergens moeten intikken om te testen?

bedankt

afbeelding van hansrossel
Door hansrossel op 22 juni, 2008 - 12:40

Dag Bram,

Als je op een shared hosting zit wordt je databasenaam en naam vaak geprefixed met de username van je account. Dus accountname_naam en accountname_databasenaam; deze moet je gebruiken in het lijntje hierboven.

Controleer ook als je de user wel effectief hebt toegevoegd aan de database bij het opzetten van je database. Dus je maakt een user, dan een database en dan voeg je de user toe gaan de database en geef je die alle privileges. Dat laatste dus niet vergeten anders heeft de user geen rechten om te connecteren met de database.

In de settings is er ook nog een lijntje waar je de root van de Drupal installatie kunt opgeven. Dit is standaard gecomment, maar als je in een subdirectory werkt kun je dit best gebruiken.
$base_url = 'http://www.example.com/drupal';
Hiervoor het sterretje weghalen en de juiste base_url opgeven.

Als het met bovenstaande niet lukt, kun je best eens met je hosting contact opnemen, want dan werkt localhost wellicht niet. Ik heb al installaties gehad bij hostingbedrijven waar je een andere naam diende te gebruiken ipv localhost, maar welke dit dan is kunnen enkel zij weten.

Ivm het laatste lijntje code dat je ergens zou moeten intikken: dit is een command line opdracht en daarvoor heb je "command line access" nodig, dus normaal gezien enkel mogelijk op een VPS of dedicated hosting (alhoewel shared hostings dit ook beginnen te bieden tegenwoordig).

Veel succes,

Hans
KOBA Webdevelopment

Hans
KOBA

Door bramp op 22 juni, 2008 - 16:44

Bedankt voor alle hulp maar ik vind het niet. Ik heb alle mogelijke combinaties geprobeerd, ik heb een mailtje gestuurd naar de host om te vragen als die 'localhost' wel correct is.

Ik zal eerst nog een cursus drupal volgen en een cursus php om wat meer te kennen over het maken van db verbindingen.

toch bedankt!

Bram

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.