afbeelding van joker

Opmaakproblemen bij drupal 8

Al een tijdje aan het stoeien met drupal8, maar ik loop toch tegen een aantal problemen aan.

Tijdens de installatie krijg ik de volgende boodschap: It is highly recommended to have OPcache installed on your server. Wanneer ik deze boodschap negeer (kan volgens mijn host) en de installatie verder laat lopen kom ik op een site zonder opmaak (zowel site- als beheerskant).

Wanneer ik op aanraden van mijn host in de eerste lijn van het .htaccess bestand in files/default/sites/ ExecCG weghaal verschijnt de opmaak wel. Dit is echter geen constante. Na wat navigeren of bij het installeren van een ander thema is de opmaak opnieuw weg. Met F5 in te drukken is hij er terug.
In de logberichten vind ik dan wel het volgende terug: Warning: base64_encode() has been disabled for security reasons in Drupal\Component\Utility\Crypt::hashBase64() (regel 130 van /home/joker/domains/jovandevoorde.be/public_html/drupal81/core/lib/Drupal/Component/Utility/Crypt.php).

Voorlopig in overleg met mijn host nog geen oplossing gevonden.

Zijn er nog drupalers die eenzelfde ervaring hebben. Ik vind er trouwens ook niets van terug op drupal.org.

grts

Auteur: 
joker
afbeelding van Stefaan Haesen
Door Stefaan Haesen op 3 januari, 2016 - 14:02

Beste,
Soortgelijk probleem hier: geen opmaak, enkel tekst op mijn drupal 8 site. Ik heb geen lijn met ExecCG in gelijk welk .htaccess bestand :-( En heb evenmin iets gevonden op drupal.org :-(

Iemand een idee ?

afbeelding van joker
Door joker op 3 januari, 2016 - 16:11

In de tweede lijn van .htaccess bestand in de map uwwebsite/sites/default/files/ staat normaal gezien het volgende: Options -Indexes -ExecCg -Includes -MultiViews.
Daar heb ik dan -ExecCG weggeknipt. Eerst schrijfrechten op 777 zetten, na wijziging terug op 444 zetten.
Op drupal.org heb ik wel iets gevonden: https://www.drupal.org/node/2620862
grts

groet
Joker

afbeelding van hansrossel
Door hansrossel op 5 januari, 2016 - 10:46

Je kunt best de css aggregatie tijdelijk afleggen om het probleem te bekijken en de cache leegmaken. Na het installeren van een nieuw theme ook de cache leegmaken.

Ivm die logs kun je best eens controleren als je hosting PHP’s base64_decode en base64_encode functies heeft aangelegd.

Lijkt me verder toch vooral problemen met je hosting die teveel zaken beperkt, bekijk ook eens https://www.drupal.org/requirements.

Hans
KOBA

afbeelding van joker
Door joker op 5 januari, 2016 - 11:41

Dag Hans, bedankt voor uw antwoord.
Had ondertussen nog contact met mijn host die actief hielp zoeken naar een oplossing. Hij denkt dat het probleem bij de Drupal 8 ligt.
Voorlopig biedt het weghalen van -ExecCG uit de tweede regel van .htaccess een oplossing.
Gezien er verdacht weinig posts verschijnen over dit probleem, ook op drupal.org blijf ik toch ook twijfelen of het niet hostgebonden is.
grts

groet
Joker

Door CDirk op 20 januari, 2016 - 18:09

Hier zelfde probleem.
De regel aanpassen helpt, maar om de één of andere reden staat daar na een paar minuten opnieuw het origineel bestand.

Dirk

afbeelding van joker
Door joker op 20 januari, 2016 - 18:35

Heb je eerst de schrijfrechten goed gezet voordat je de wijziging doorvoerde?

groet
Joker

Door CDirk op 21 januari, 2016 - 21:00

Dat had ik inderdaad over het hoofd gezien. Nu wel aan de praat gekregen.
Dirk

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee