afbeelding van Kristina

opslag

Ik heb een website gebouwd met drupal. die gaat al een vijftal jaren mee. Ik doe regelmatig updates, recent ook de php versie verhoogd omdat de server dit vereiste.
Nu is mijn website plots niet meer te vinden vanwege een tekort aan beschikbare ruimte.
Ik krijg een foutmelding: Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 536870920 bytes) in /customers/d/7/f/kristienberings.be/httpd.www/boek/includes/theme.inc on line 98
Het probleem zou volgens de helpdesk van de server bij het Thema Bartik liggen.
Ik kan ook niet inloggen op mijn website en zo ook niets doen.
Kan iemand mij helpen.

BijlageGrootte
Image icon Op zoek naar ini86.31 KB
Image icon Op zoek naar memory93.77 KB
Drupalversie: 
7.x
Auteur: 
Kristina
afbeelding van jo.w
Door jo.w op 27 december, 2018 - 15:23

Dit is geen tekort aan beschikbare ruimte maar een tekort aan geheugen op de server. Je moet je php-limit verhogen.
De eerste oplossing die Google geeft: https://www.drupal.org/node/76156

Jo

afbeelding van Kristina
Door Kristina op 27 december, 2018 - 17:41

Dankjewel, ik probeer de instructies te volgen. Ik maakte het myinfo.php bestand met daarin de code <?php phpinfo(); ?> en ik vond de pagina bij http://kristienberings.be/boek/myinfo.php
Ik stuur een screenshot waar ik ini zoek maar ik weet nu niet waar ik die php.ini file kan vinden.
/etc zie ik niet in mijn bestanden. Kan je mij nog wat verder helpen.

afbeelding van jo.w
Door jo.w op 27 december, 2018 - 17:55

Ik heb ff verder gekeken naar je site en als ik zie waar de domeinnaam geregistreerd is dan houd ik mijn hart al vast (bij wijze van spreken natuurlijk).

De meeste hostingbedrijven laten je niet bij php.ini komen en deze zeker niet.

Je zou kunnen proberen om onderstaande aan settings.php toe te voegen maar ook dat is niet zeker of ze 't toestaan.
ini_set('memory_limit', '1024M');

Waar php.ini staat zie je trouwens in de 5e rij van de eerste tabel van myinfo.php. memory_limit vind je trouwens terug in de tabel "core".

Jo

afbeelding van Kristina
Door Kristina op 27 december, 2018 - 18:10

Ja, dat is dus /etc/php
Ik had eerder al de helpdesk van one.com geraadpleegd. Zij denken dat het ligt aan het theme dat ik gebruik. Ze zeggen dat het te zwaar is. Ik gebruikt Bartik, een standaard thema. Daar heb ik ook een child-theme van gemaakt.
Ik wil wel eens proberen met een ander thema maar nu kan ik niet bij de back-end van mijn website komen en bijvoorbeeld eens proberen een ander theme te kiezen. Ik ga normaal gezien altijd naar de back-end via een inlogpaneeltje op mijn website maar wellicht kan ik daar op een andere manier naartoe gaan. Weet je hoe?

afbeelding van jo.w
Door jo.w op 27 december, 2018 - 18:25

Ze denken maar ze denken verkeerd.
Heb je geen inloggegevens waar je bij je bestanden, je database, je mailinstellingen en dergelijke meer kan komen?
Andere hostingbedrijven gebruiken daarvoor DirectAdmin, of cPanel, of Plesk. De eerste 2 kan ik zelf mee overweg maar ik weet natuurlijk niet wat one.com gebruikt.

En voor je themes gaat veranderen (bartik is nu niet zo'n zwaar theme, denk ik) probeer eerst maar die regel toe te voegen aan settings.php.

Jo

afbeelding van Kristina
Door Kristina op 27 december, 2018 - 19:42

Ik heb een regel toegevoegd aan settings.php, nl. ini_set('memory_limit', '1024M'); Maar ik krijg dezelfde foutmelding als voorheen:Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 536870920 bytes) in /customers/d/7/f/kristienberings.be/httpd.www/boek/includes/theme.inc on line 98

Ik heb toch nog eens gekeken in dat bestand theme.inc. Dit is het stukje code van regel 93 tot 100:
// Find all our ancestor themes and put them in an array.
$base_theme = array();
$ancestor = $theme;
while ($ancestor && isset($themes[$ancestor]->base_theme)) {
$ancestor = $themes[$ancestor]->base_theme;
$base_theme[] = $themes[$ancestor];
}
_drupal_theme_initialize($themes[$theme], array_reverse($base_theme));

regel 98 bevat enkel dit: $base_theme[] = $themes[$ancestor];

afbeelding van jo.w
Door jo.w op 28 december, 2018 - 02:43

Als je niet heel goed thuis bent in php ga je daar ook niets vinden wat je kan helpen.
Er is nog een mogelijkheid om een stukje code toe te voegen aan .htaccess ook:

php_value memory_limit xxxM

Aangezie je al ruim boven de 500MB zit zou ik in de plaats van xxx 700 of meer zetten maar ook hier; het kan ziijn dat one.com het niet toe staat om op die manier je memory_limit te verhogen.
Voor je dit toepast wel de regel uit settings.php weer weg halen.

Een andere optie is om weer naar een lagere php-versie terug te schakelen en dan kijken wat er eventueel van modules kan uitgeschakeld worden.

Jo

afbeelding van Kristina
Door Kristina op 31 december, 2018 - 13:19

php_value memory_limit 700M wordt niet aanvaard door one.com
Ik krijg een andere foutmelding. Dit heb ik alweer verwijderd uit de de .htaccess
En dan de php versie, die had al ik zo laag mogelijk gezet maar lager dan 7.1 kan ik niet gaan.
Ik heb nu opnieuw contact opgenomen met one.com en gevraagd om de geheugencapaciteit tijdelijk te verhogen zodat ik bij de website kan komen en dan een aantal modules weghalen. Nog geen antwoord gekregen.

Intussen al antwoord gekregen dat ik niet bij de php.ini kan. Dat de enige oplossing is modules te verwijderen. Ik heb er geen idee van welke modules ik mag verwijderen. Ik heb er nu lukraak een heleboel weggedaan maar de foutmelding is nog steeds identiek dezelfde: Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 536870920 bytes) in /customers/d/7/f/kristienberings.be/httpd.www/boek/includes/theme.inc on line 98
Ik ben ten einde raad. Mijn site is een boekensite waarop vrienden sinds een drietal jaren hun gelezen boekbesprekingen plaatsen. Ik moet die site zo snel mogelijk weer online hebben.

afbeelding van jo.w
Door jo.w op 31 december, 2018 - 15:43

Ik hoop dat je genoteerd hebt welke modules je gewist hebt!

Er is maar één goeie oplossing: download alles, zowel bestanden als database en ga zo snel mogelijk over naar een hostingbedrijf wat wél geschikt is voor Drupal.

Jo

afbeelding van Niek Kloots
Door Niek Kloots op 27 december, 2018 - 21:10

Bartik en de andere core themes zijn niet zwaar dus grote onzin wat one.com zegt.

Je zegt, dat je Bartik gebruikt, maar dan is die van jou wel flink aangepast.
Ik zie er niets van terug in view-source:https://kristienberings.be/

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

afbeelding van jo.w
Door jo.w op 27 december, 2018 - 21:45

Volgens ik uit éea kan opmaken staat het drupal-deeltje van de site op https://kristienberings.be/boek

Jo

afbeelding van Niek Kloots
Door Niek Kloots op 31 december, 2018 - 14:36

Dat de enige oplossing is modules te verwijderen.

Alle modulen behalve de meeste core modulen mag je uitschakelen/verwijderen.

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

afbeelding van jo.w
Door jo.w op 3 januari, 2019 - 15:27

Een copie van de site draait momenteel zonder enig probleem of zonder enige aanpassing op hosting waar ik beschikking over heb. Het ligt dus volledig aan one.com.

Jo

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee