PHP_VERSION

Het gaat hierbij om de initiële installatie:

De versie PHP op de server is versie 5.5.38, echter nadat het invulscherm voor de databasegegevens voor installatie is ingevuld en de eigenlijke installatie begint, komt er direct een melding:

<?php
/**
* @file
* Initiates a browser-based installation of Drupal.
*/
define('DRUPAL_ROOT', getcwd());
/**
* Global flag to indicate the site is in installation mode.
*/
define('MAINTENANCE_MODE', 'install');
// Exit early if running an incompatible PHP version to avoid fatal errors.
if (version_compare(PHP_VERSION, '5.2.4') < 0) {
print 'Your PHP installation is too old. Drupal requires at least PHP 5.2.4. See the system requirements page for more information.';
exit;
}
// Start the installer.
require_once DRUPAL_ROOT . '/includes/install.core.inc';
install_drupal();

De installatie ziet de versie van PHP niet en ik kan dit dus niet installeren, aangezien dit bestand gegenereerd wordt.
Als de versie opgevraagd wordt, is dit:
[~] # /usr/local/apache/bin/php -version
PHP 5.5.38 (cli) (built: Dec 14 2016 03:30:23)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies

Hoe nu verder?

Auteur: 
SHofstra
afbeelding van be-web
Door be-web op 30 januari, 2017 - 16:12

Dit is geen melding, dit is de broncode van index.php. Je server staat niet goed ingesteld om .php bestanden te verwerken. Wellicht even met de provider bellen.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.