afbeelding van Jef Bruyninckx

Trusted Host Settings

Ik installeer meerdere drupal8-sites in een resellerpakket. Bij twee gaat/ging het goed maar nr. 3 doet moeilijk:

Na de installatie wil ik de trusted host settings verbeteren. Daarvoor moet ik in settings.php de volgende instructie toevoegen:
Verander de rechten van de map default en het bestand settings.php naar 777
open het bestand in een editor via het bestandsbeheer van uw cpanel en voeg onderstaande code toe
$settings['trusted_host_patterns'] = array(
  '^www\.domeinnaam\.be$',
  '^domeinnaam\.be$',
);
Sla de veranderingen op
Vergeet de rechten niet terug te zetten:
map Default naar 0555
bestand settings.php naar 0444

Dat voer ik correct uit MAAR daarna ben ik mijn site kwijt met de laconieke melding dat er een onverwachte fout is opgetreden en dat ik het later nog maar eens moet proberen.

Drie keer herbegonnen, drie keer fout gegaan

Weet er iemand raad?

Drupalversie: 
8.x
Auteur: 
Jef Bruyninckx
afbeelding van Niek Kloots
Door Niek Kloots op 10 september, 2018 - 21:46

Waarom gebruik jij niet de settings.php, van een van de twee sites, die wel werkt?
Alleen de domeinnaam aanpassen en de gegevens van de database aanpassen.

Daarnaast ook de htaccess van die werkende site gebruiken.

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

afbeelding van Jef Bruyninckx
Door Jef Bruyninckx op 11 september, 2018 - 18:27

Ik heb van mijn hostingsupport de volgende oplossing aangereikt gekregen (met heel veel dank Neostrada!):
Het zit in de laatste regel, wat verder naar boven in de settings.php heeft Drupal al de code staan echter als comment en bij de host settings example.com
Je kunt de betreffende code uncommenten door de regel erboven af te sluiten met */ en de regel onder de betreffende code weer te beginnen met /*
Indien je de editor binnen cPanel gebruikt zul je de kleuren ook zien veranderen (grijs is comment).
Ten slotte dien je bovenaan de .htaccess de onderstaande code te plaatsen:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule .* https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Met de host settings wordt namelijk standaard enkel www.domein.nl toegestaan, met de betreffende code wordt er een doorverwijzing ingesteld naar https://www.
--
Met vriendelijke groet,
Tjeerd Bikker
Neostrada B.V.
Inde hoop dat er nog drupallers wat aan hebben... Succes ermee8
Jef Bruyninckx

afbeelding van Niek Kloots
Door Niek Kloots op 11 september, 2018 - 19:52

Bedankt voor het delen.
Zoals ik al zei en je zelf al schrijft: htaccess moet ook aangepast worden.

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

afbeelding van jo.w
Door jo.w op 12 september, 2018 - 09:56

Blijft de vraag waarom het bij 2 sites op hetzelfde hostingpakket wel gewerkt heeft en bij de derde niet. Of toch een typfoutje gemaakt?

Jo

afbeelding van joker
Door joker op 11 september, 2018 - 18:55

bedankt voor het delen

groet
Joker

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee