xcache error

Ik heb op mijn nieuw hostingpakket Drupal 8.6.1 geinstalleerd via het cpanel.

Als ik echter naar mjn url ga krijg ik een scherm vol Warnings :
“””””””
Warning: xcache_isset(): XCache var cache was not initialized properly. Check php log for actual reason in /home/bellamad/public_html/vendor/symfony/class-loader/XcacheClassLoader.php on line 120
“””””””

Weet niet hoe ik dit moet vermijden.

Iemand een idee.

Bedankt alvast.

Drupalversie: 
8.x
Auteur: 
MVC
afbeelding van Niek Kloots
Door Niek Kloots op 25 september, 2018 - 17:30

Als er Warnings komen na een update moet je gewoon de update nogmaals uitvoeren.

Misschien helpt dat hier ook?

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

Door MVC op 25 september, 2018 - 18:14

Is niet na een update. Is bij een fresh install, maar wel via cpanel van de service provider.
Heb al opnieuw geïnstalleerd maar zelfde resultaat.

afbeelding van joker
Door joker op 25 september, 2018 - 19:12

Neem eens contact op met je host.

groet
Joker

Door MVC op 25 september, 2018 - 20:13

Heb ik al gedaan, maar voorlopig geen oplossing.
Gezien de error verwijst naar een file in de publieke html folder die gecreëerd is door de Drupal installatie ging ik er vanuit dat het een Drupal issue is.

afbeelding van Niek Kloots
Door Niek Kloots op 26 september, 2018 - 03:29

Wat als je een kale D8 installatie helemaal zelf uitvoert?
Dus zelf een database aanmaken en zelf de core bestanden via ftp uploaden.

Daarna de uitbreidingen per module doen en kijken of en waar het mis gaat.

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

Door MVC op 26 september, 2018 - 07:34

Niek,

Had ik inderdaad ook al aan gedacht, maar wilde dit eigenlijk vermijden gezien het extra werk.
Als het niet anders kan zal ik het uiteindelijk wel moeten proberen maar ik dacht, aangezien er een duidelijke foutboodschap is, dat het probleem makkelijker moet op te lossen zijn.

afbeelding van jo.w
Door jo.w op 26 september, 2018 - 09:45

Als ik wat ga googlen lijkt het me geen Drupal-probleem maar een php-probleem. Deze lijkt me er ééntje om eens aan je hostingbedrijf voor te leggen: https://www.prestashop.com/forums/topic/365483-how-to-fix-error-in-cache/

Je zegt dat je je site geïnstalleerd hebt via cPanel maar welke installer zit daar op want je hebt er meerdere.
Softaculous geeft wel wat mogelijkheden om de installer te "bedriegen".
Als je een installatie doet via ftp kan je ze nadien niet bijwerken via Softaculous. Je kan wel eerst een installatie doen via Softaculous, alle bestanden weg gooien, terug plaatsen via ftp en dan blijft Softaculous nadien aangeven als er updates zijn.

Of Installatron gelijkaardig werkt weet ik niet.

Jo

Door MVC op 26 september, 2018 - 10:24

Bedankt. Ik ga deze info inderdaad doorsturen, want lijkt inderdaad geen Drupal issue.
Het capnel dat ik heb werkt met Installatron trouwens.

afbeelding van Niek Kloots
Door Niek Kloots op 26 september, 2018 - 11:56

Verkeerde PHP versie misschien? Draait het wel op PHP 7.x ?
D8 op een PHP 5 versie werkt niet lekker.

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

Door MVC op 26 september, 2018 - 14:39

PHP versie is 5.6.27.
Is nog altijd wel gesupporteerd.

afbeelding van Niek Kloots
Door Niek Kloots op 26 september, 2018 - 21:43

Supported? Ja vanaf PHP 5.5.9+ aanbevolen NEE

En daar je toch een nieuwe site aan het bouwen bent, dan kan je beter meteen met de laatste PHP versie beginnen.
https://www.drupal.org/docs/8/system-requirements/php-requirements

Drupal will work on all supported PHP versions. Recommended PHP versions are the best choice for building a Drupal site because they will remain supported longer. PHP 7 also has significant speed and caching improvements.

PHP 5.5 has already reached its official end-of-life, and PHP 5.6 and 7.0 will reach their end-of-life at the end of 2018. (See PHP: supported versions for more information.)
Drupal 8 will drop support for PHP 5.5 and 5.6 on March 6, 2019.
We recommend updating to at least PHP 7.1 if possible, and ideally PHP 7.2, which is supported as of Drupal 8.5.0 (release date: March 7, 2018).

http://familiekloots.nl
hobby: https://noww.nl, https://dldsa.nl en http://openwaterswimming.eu

Door MVC op 26 september, 2018 - 22:35

Zou inderdaad de beste oplossing zijn (al denk ik niet dat dat het probleem is) maar ik kan de php versie niet zo maar zelf veranderen op het hostingpakket.

afbeelding van jo.w
Door jo.w op 27 september, 2018 - 13:40

Bij mijn hosting kan ik in cPanel onder het kopje "software" de php-versie zelf kiezen (uit 5.6, 7.0, 7.1 en 7.2).

Jo

Door MVC op 27 september, 2018 - 22:42

Ondertussen heeft de provider een nieuwe installatie gedaan met een andere versie van cpanel (PHP 7.2).
De installatie van dDrupal ging nu vlekkeloos.

Bedankt voor alle hulp !

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee