Deprecated function

Het lukt me niet om een upgrade te doen.

Deze melding komt in mijn scherm
Nieuwe versie voor veiligheid vereist!fout
Drupal core 7.34
Hoe kan ik dit oplossen?

BijlageGrootte
Image icon DrupalMelding.png201.96 KB
Drupalversie: 
7.x
Auteur: 
Jaap van der Heijden
afbeelding van Niek Kloots
Door Niek Kloots op 26 april, 2021 - 17:15

De huidige Drupal versie is Drupal-7.80 dus je loopt flink achter. D7.34 is van 18 Maart 2015

Probeer het handmatig met versie 7.35 Dus geen Composer of Drush e.d. gebruiken.
Lukt dat wel?
Zo ja dan een volgende update bijvoorbeeld versie 7.40 doen etc. tot je weer bij bent.

Hier kan je alle core updates vinden. https://www.drupal.org/project/drupal/releases?version=7

afbeelding van belba
Door belba op 28 april, 2021 - 12:22

Beste Jaap

De foutmelding heeft je al de oplossing. De each() functie is deprecated.
Zie de informatie van PHP zelf
Je zal moeten uitzoeken waar die functie gebruikt wordt en ze wijzigen.

Succes, Jan

afbeelding van Jurgen M
Door Jurgen M op 20 mei, 2021 - 14:53

De foutmelding zit in includes/menu.inc bestand.
Dit is een core bestand, dus doen wat Niek al aanrade, drupal core updaten.
Kijk ook even welke php versie er op de server draait. Die zou minimaal php 7.2 en liefst 7.3 moeten zijn.

afbeelding van Niek Kloots
Door Niek Kloots op 20 mei, 2021 - 15:08

Updaten meteen naar de laatste versie lukt Jaap blijkbaar niet.
Mijn advies is dus om het in kleinere stappen te doen.

Jaap, ben benieuwd of het zo wel lukt/ of mijn advies gewerkt heeft.

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee