Drupal 5.6 template op Drupal 5.1

een klant van ons heeft Drupal 5.1 draaien en heeft ons gevraagd een theme te maken.
kunnen wij probleemloos een templete maken in een andere Drupal versie, bijvoorbeeld 5.6 of 6.2 ?

Auteur: 
burning raven
afbeelding van svendecabooter
Door svendecabooter op 11 april, 2008 - 10:12

Als je een andere Drupal versie in de 5.x branch installeert, kan je daarop een theme maken die ook op hun 5.1 installatie zonder problemen zou moeten werken. Als je Drupal 6.x installeert, zal dit echter hoogstwaarschijnlijk problemen geven, daar er (als ik het goed heb) een aantal wijzigingen mbt theming zijn doorgevoerd in 6.x.

--
releasedata.be - Belgische releasedatums van muziek, film en games

Door burning raven op 11 april, 2008 - 10:48

ok, dan weet ik voldoende voorlopig :)

bedankt!

afbeelding van Xano
Door Xano op 11 april, 2008 - 15:04

Je moet er gewoon vanuit gaan dat als het major version number (5 in 5.6 of 6 in 6.2) overeenkomt dat het dan compatible is. Het patch nummer (6 in 5.6, 2 in 6.2) maakt wat compatibiliteit in principe niets uit, behalve in speciale gevallen (tot en met Drupal 4 bijvoorbeeld. Nu ook weer met een zeer kleine API-wijziging in 6.2).

Alles wat voor Drupal 5.0 gemaakt is zal ook voor Drupal 5.946 werken, stel dat die er ooit komt. Je Drupal 6 template werkt niet op Drupal 5, maar waarschijnlijk ook niet op 7 als die uitkomt.

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

afbeelding van george@dynapres.nl
Door george@dynapres.nl op 17 april, 2008 - 10:26

Dynapres.nl

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee