afbeelding van Vincentje

Foto's niet zichtbaar

Ik heb een drupal 8 website geüpload naar een tijdelijke domein (geen SSL). Nu zijn de foto's nergens zichtbaar. Als ik naar het pad kijk in de drupal instellingen dan staat dit juist. De foto's staan ook in de opgegeven map (pad) en de rechten staan op 777.
Lokaal zie ik wel de foto's. Zou er ergens in een php bestand van de template iets kunnen staan waardoor ik geen foto's kan zien. Of ie het een andere instelling?

Alvast bedankt voor de hulp

Drupalversie: 
8.x
Auteur: 
Vincentje
afbeelding van Niek Kloots
Door Niek Kloots op 16 oktober, 2020 - 19:23

Je moet de foto's dus kunnen zien als je het juiste pad intikt.
Is de bestaande site wel in https://
Heb je het lokale pad zowel met http:// als https:// geprobeerd?

afbeelding van Vincentje
Door Vincentje op 16 oktober, 2020 - 22:10

Als ik het pad van een foto zo ingeef http://www.drupalweb.site/sites/default/files/inline-images/foto_visie.jpg krijg ik een fout bericht nl code 500
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@drupalweb.site to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.

Mijn website is ook maar te bereiken als ik www ervoor zet.
Kan dit ook met het probleem te maken hebben?

Vincent

afbeelding van Jurgen M
Door Jurgen M op 17 oktober, 2020 - 09:01

Als de afbeeldingen in de map inline-image staan dan zijn dat afbeeldingen zoals het logo en afbeeldingen die je binnen ck-editor hebt geplaatst.
Zet uw ck-editor tekstopmaak op full html. Dan zullen de foto's waarschijnlijk wel zichtbaar zijn.

afbeelding van Vincentje
Door Vincentje op 17 oktober, 2020 - 17:58

Dag Jurgen
Hij staat op full html en ze zijn toch niet zichtbaar

Vincent

afbeelding van Niek Kloots
Door Niek Kloots op 16 oktober, 2020 - 22:44

http://www.domein.nl of http://domein.nl of https://www.domein.nl of https://domein.nl
Dat maakt in principe allemaal niets uit. (Geloof aleen, dat Google het liefst de laatste heeft)
Je kan de link, die men intikt allemaal omleiden naar die welke jij zelf wilt m.b.v. .access en settings.php

Met die verkregen 500 fout lijkt er iets niet goed te zijn gedaan.
uitleg https://www.strato.nl/handboek/http-error-500-oorzaken-en-oplossingen

Daarom mijn vraag kan je de website domein.nl wel zien. Zo ja, dan gaat er iets mis bij het vinden van de map ..../sites/default/files/inline-images .
Zo nee, dan moet het pad naar de website in .access en/of settings.php anders gedaan worden.

afbeelding van Vincentje
Door Vincentje op 17 oktober, 2020 - 18:00

Dag Niels het rare is dat ik niets vind in het settings.php en het access bestand die verwijst naar één of andere map.
www.drupalweb.site is zichtbaar zonder foto's. Nog nooit problemen gehad met zoiets erf vreemd. Op wamp (lokaal) zie ik ze wel.

Vincent

afbeelding van Jurgen M
Door Jurgen M op 27 oktober, 2020 - 11:06

Als ik naar www.drupalweb.site ga krijg ik enkel een wit scherm te zien.
Wat je ook kan doen is volgend:
Ledig de cache op je local server.
Load de site opnieuw op naar de server.
Importeer de database opnieuw.
Gooi settings.php weg.
Surf nu naar de website en je krijgt de install pagina te zien.
Vul de gegevens van de database in.
Als alles goed is krijg je dan de melding dat er reeds een database aanwezig is en kan je klikken om naar de website te gaan.
Ledig de cache
Zet trusted host in settings.php weer goed.

Succes

afbeelding van belba
Door belba op 21 oktober, 2020 - 11:53

Heb vroeger dat probleem gehad bij Sohosted. De oplossing was toen in de map sites/default/files het .htacces bestand aan te passen. Alle code als commentaar zetten. Dat kan je eens proberen. Dan weet je tenminste of het daar aan ligt. Dan uitvissen welke regel verantwoordelijk is.

Succes, Jan

afbeelding van Niek Kloots
Door Niek Kloots op 27 oktober, 2020 - 11:42

Er is als het goed is een htaccess bestand in je map files.
In de mijne staat het onderstaande:

# Turn off all options we don't need.
Options None
Options +FollowSymLinks

# Set the catch-all handler to prevent scripts from being executed.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006

# Override the handler again if we're run later in the evaluation list.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2013_003

# If we know how to do it safely, disable the PHP engine entirely.

php_flag engine off

# PHP 4, Apache 1.

php_flag engine off

# PHP 4, Apache 2.

php_flag engine off

# Protect files and directories from prying eyes.

Order allow,deny

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.