Foutmelding bij nieuwe site

Hallo,

Ik heb een website draaien in Drup versie 5.2, nu ben ik bezig met een nieuwe site en wil deze ergens op de server plaatsen zodat ik met meerder mensen aan deze nieuwe site kan werken.
Ik heb het volgende gedaan:
- Bij de provider een nieuwe DB aangemaakt genaamd twn_solaris
- In de files directory waar ook de huidige website draaid een map aangemaakt genaamd solaris
- De file default/settings.php aangepast
dit als volgt
'driver' => 'mysql',
* 'database' => '@db01.instantxs.net:3306/twn_solaris',
* 'username' => 'root',
* 'password' => 'password',
* 'host' => 'localhost',
* 'port' => 3306,
* 'prefix' => 'drupal_',
* 'collation' => 'utf8_general_ci',

Als ik dan op internet ga en de site zichtbaar probeer te krijgen, krijg ik onderstaande foutmelding:

PDOException: SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: YES) in lock_may_be_available() (line 167 of /var/www/vhosts/almen-info.nl/httpdocs/solaris/includes/lock.inc).

Ik gebruik als internet naam de www.almen-info.nl/solaris/

Kan iemand mij vertellen waar dit fout gaat,
Alvast bedankt voor de hulp,
Groet
mst

Drupalversie: 
7.x
Auteur: 
mstrep
afbeelding van be-web
Door be-web op 9 december, 2012 - 20:16

Je dient in ieder geval 'root' en 'password' te vervangen door de daadwerkelijke inlognaam en wachtwoordcombinatie die je gebruikt voor je database (denk erom dat je deze gegevens hier niet plaatst in een evt. vervolgbericht). Als je dan nog steeds dezelfde melding krijgt, dien je mogelijk nog een gebruiker en rechten toe te kennen aan de database, maar dat is meestal niet nodig.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door mstrep op 9 december, 2012 - 20:35

Hallo Be-web,

Ik heb dit toegevoegd met de inlognaam en wachtwoord welke ik had aangemaakt als gebruiker van de DB.
Ook dit blijft dezelfde fout geven !!

Gr mst

afbeelding van be-web
Door be-web op 9 december, 2012 - 21:42

- Klopt het '@'-teken in de databasenaam?
- Is de host wel 'localhost' of moet dat misschien iets anders zijn bij je provider?
- Kun je met de inloggegevens wel bij de database via bij PHPMyAdmin?

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door mstrep op 10 december, 2012 - 07:09

-Het @staat in de DB naam, ik draai dit via plesk parralel. Wat ik even niet weet is het volgende.
Ik heb bij het aanmaken van de DB een gebruiker aangemaakt. ik gebruik deze gebr. naam en wachtwoord in
settings.php. Vervolgens ga je naar webadmin en daar laad je de data.sql file. Op deze manier heb ik de DB
met mysql geladen. Moet je hier ook nog een wachtwoord opgeven?
-Ik zag ook bij de pagina welke reeds draaid dat bij de database url begint met
'mysql://gebr.naam:w8woord@servernaam/database naam

Het moet ergens fout staan maar waar.
Gr. mst

afbeelding van be-web
Door be-web op 10 december, 2012 - 09:19

De gebruiker die je hebt aangemaakt bij de database, heeft deze wel genoeg rechten op de database, of moet dat apart ingesteld worden ? Ik heb geen ervaring met Plesk. Misschien een andere meelezer.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door mstrep op 10 december, 2012 - 20:36

Ik ben nog even aan het puzzelen geweest en ben weer een stap verder,ik krijg nu geen foutmelding van drupal maar nu krijg ik dit:
Your php installation is to old, Drupal requires at least 5.2.4 Als ik vervolgens weer naar Plesk ga dan zie ik bij de DB dat PHP myadmin 2.8.2.4 is en mysql versie = 5.1.63.
He kan ik dit oplossen. Ik zou denken dat een provider de laatste software op zijn server heeft??
Gr. mst

afbeelding van jo.w
Door jo.w op 10 december, 2012 - 23:53

Jij kan dat niet zelf oplossen. Je kan enkel het hostbedrijf vragen te updaten naar volgende versies:

Web server
Apache, Nginx, or Microsoft IIS
Database server
Drupal 6: MySQL 4.1 or higher, PostgreSQL 7.1,
Drupal 7: MySQL 5.0.15 or higher with PDO, PostgreSQL 8.3 or higher with PDO, SQLite 3.3.7 or higher
Note: Microsoft SQL Server and Oracle are supported by an additional module
PHP
Drupal 6: PHP 4.4.0 or higher (5.3 recommended)
Drupal 7: PHP 5.2.5 or higher (5.3 recommended)--some of the modules require 5.3
bron: http://drupal.org/requirements

Jo

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee