afbeelding van tamtamhen

gebruik van composer voor upgrade

Heeft er iemand een simpele handleiding om composer te gebruiken voor een upgrade van de core op een gebruiksvriendelijke manier?

Ik heb ooit een command gevonden dat werkte, maar nu niet meer:
composer require drupal/core-recommended:9.1.2 drupal/core-composer-scaffold:9.1.2 --update-with-dependencies

Met wat gefoefel in composer.json en/of composer.lock wil dat na veel proberen en zoeken de update uitvoeren, mogelijk na het uitvoeren van 'composer update'.Ik probeer dan zoveel dat ik niet meer weet wat ik juist gedaan heb.

Dus ik wou ook weer updaten naar 9.1.4. Dus zie mijn pogingen in bijvoesel.

In een tweede bijvoegsel is er finaal een geslaagde update na dat gefoefel in composer.json en composer.lock

Als ik de documentatie gebruik op de site van Drupal dan lukt dat helemaal niet.

Vandaar mijn vraag: wat is de gebruiksviendelijke manier zonder veel gezoek?

BijlageGrootte
Plain text icon Niet geslaagde pogingen tot update via composer10.23 KB
Plain text icon Uiteindelijk wel geslaagde poging tot update7.74 KB
Drupalversie: 
9.x
Auteur: 
tamtamhen
Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee