hoe het programma openen

Hoe kan ik het programma Drupal 6 openen? Ben een totale leek

Auteur: 
wdr
afbeelding van Xano
Door Xano op 7 juni, 2008 - 01:38

Hey, welkom hier op Drupal.be!

Ik zag in je andere topic al dat je het *.tar.gz bestand niet kon downloaden, dus ik zal daar met het verhaal beginnen. Welk besturingssysteem heb je? In het geval van Windows, download dan Winrar. Heb je OS X, dan kan je UnrarX downloaden. Een *.tar.gz bestand is een soort geavanceerd zip-bestand en met deze programma's kan je dergelijke bestanden openen.

Drupal is een CMS, geprogrammeerd in de taal PHP. Om dit te draaien heb je een webserver nodig die PHP ondersteunt. De meeste hostingproviders (bedrijven die jou ruimte verhuren om je website op te laten draaien) ondersteunen dit standaard, maar als je zelf op je eigen computer wil testen, dan kan je een pakket downloaden wat dit voor je verzorgt. Voor Windows is dat Xampp Lite, voor OS X is dat MAMP. Dit installeer je op je computer en vervolgens start je deze "programma's". Hierna stop je de bestanden die je hebt gekregen door het eerder genoemde *tar.gz bestand uit te pakken in de web root. Je web root is de map in je webserver waar al je sites in staat. Voor Xampp wordt dat waarschijnlijk C:\Xampp\htdocs\, voor MAMP is dat /Applications/MAMP/htdocs/.

Nu ga je met je browser naar 'localhost'. Geen www ervoor intikken, gewoon 'localhost'. Dit betekent dat je browser op jouw eigen computer moet gaan kijken naar websites. Waarschijnlijk krijg je nu de foutmelding dat er geen database gevonden kon worden.

Bij een hostingprovider is er meestal al een database voor je aangemaakt, maar omdat je nu voor jezelf een eigen webserver hebt aangemaakt is er natuurlijk nog geen database aanwezig. Download phpMyAdmin en zet deze ook in je web root. Open deze vervolgens met je browser en maak een nieuwe database met het type "utf-8 unicode" aan. Ga nu weer met je browser naar 'localhost' en je kan Drupal installeren. Het type van je database is 'mysql', de gebruikersnaam is 'root' en het wachtwoord is blanco.

Nu even stapsgewijs en in het kort:

  1. Voor Windows Winrar of voor OS X UnrarX downloaden en installeren.
  2. Vervolgens het gedownloaden *.tar.gz bestand van Drupal uitpakken.
  3. Voor Windows Xampp Lite of voor OS X MAMP downloaden en installeren.
  4. De uitgepakte Drupal bestanden in je web root zetten: C:/Xampp\htdocs\ (Windows) of /Applications/MAMP/htdocs/ (OS X)
  5. Download phpmyadmin en zet deze ook in je web root.
  6. Met je browser naar 'localhost' gaan en Drupal installeren.

Veel succes en veel plezier!

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

Door ICAP op 16 juni, 2008 - 23:21

Hoi Xano,

Ik volgde jouw instructies tot aan:

na download phpMyAdmin en in de web root te hebben gezet, zeg jij: open in browser, en maak nieuwe database met type utf-8 unicode aan.
Hoe doe je dat?

Thx,
ICAP

afbeelding van Xano
Door Xano op 17 juni, 2008 - 09:44

Ook weer in je browser naar je eigen webserver gaan en phpMyAdmin openen. In het hoofdscherm staat vervolgens de mogelijkheid een nieuwe database te maken.

Nederdev : webdesign en -development

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

Door ICAP op 17 juni, 2008 - 11:06

Ik ben volledig herbegonnen.
op XP.
download Winrar/ download drupal 6.2/ download Xampp Lite + install op de C./ de uitgepakte drupal bestanden onder Xampp\htdocs geplaatst.
als ik nu localhost opstart in Firefox krijg ik foutboodschap:

Website does not supply identity information/your connection to this website is not encrypted.

wat doe ik verkeerd?
thx

afbeelding van Xano
Door Xano op 17 juni, 2008 - 14:10

Die melding ken ik niet. Opzich zou het ook niet mogen uitmaken dat de verbinding niet versleuteld is. Heb je toevallig je beveiligingsinstellingen aangepast in Firefox? Check anders een andere browser even. Dan weten we of het aan Xampp of aan Firefox ligt.

Nederdev : webdesign en -development

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

afbeelding van Xano
Door Xano op 17 juni, 2008 - 21:10

Gebruik je trouwens FF3? Ik heb hem nu ook gedownload en kwam die melding toevallig ook tegen (maar dan bij groups.drupal.org). Kan volgens mij geen kwaad.

Nederdev : webdesign en -development

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

Door ICAP op 17 juni, 2008 - 12:53

daar ik geen antwoord krijg, probeer ik nu phpmyadmin. Deze gedownload en in de web root gezet.
wanneer ik via browser file wil openen en kies voor install; krijg ik volgende:

Please have a look to the documentation text or documentation html files...

het lukt dus niet.

Ik zit in de mist !

Door ICAP op 19 juni, 2008 - 16:42

Hoi Xano,
Ik heb alles verwijderd en ben opnieuw begonnen.
Alles prima gelukt behalve...
nadat ik database toegevoegd heb: utf-8 unicode in phpMyAdmin
ben ik terug naar "localhost" gegaan en ...
hoe moet ik nu Drupal installeren? (waar vind ik de exe? in de root onder map Drupal ...?)
thx

afbeelding van Xano
Door Xano op 20 juni, 2008 - 14:54

Drupal is geen programma, het is een CMS dat geschreven is in de taal PHP. De omgeving waarin PHP uitgevoerd kan worden is je webserver, die jij dus in de vorm van Xampp geïnstalleerd hebt. Drupal beheer je in principe via je browser. Als Drupal in /xampp/htdocs/drupal-test staat, dan ga je in je browser naar 'localhost/drupal-test'. Daarna kan je de instructies op het scherm gewoon volgen.

Nederdev : webdesign en -development

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

Door ICAP op 21 juni, 2008 - 15:50

Ik begrijp dat Drupal geen programma is. De omgeving waarin PHP uitgevoerd kan worden is mijn webserver. OK.
Maar de installatie, zoals jij hierboven beschreef lukt me niet !
Ik heb alle vorige pogingen van C verwijderd.
Ik heb Xampp Lite gedownload in C. gevolg: er is een map Xampplite aangemaakt met de bestanden erin. Vervolgens via Xampp control Panel zie ik: Mysql (status 1 service 0 start 0 poort 3306) Wat betreft Apache is de status 0 Service 1 start 0 poort 80. Nu Drupal 6.2 via Winrar uitgepakt en geplaatst in c:xampplite/htdocs/Drupal 6.2. Nu download phpMyAdmin en ook gezet in c:xampplite/htdocs/phpMyAdmin.
Gezien het in een vorige keer gelukt was om een nieuwe database utf-8 unicode aan te maken, vraagt hij nu niks meer als ik in browser localhost oproep.
Nu zou ik dus Drupal kunnen installeren...Maar als ik in localhost naar C/Xammpplite/ htdocs/drupal6.2 ga en klik op install php krijg ik een venster volledig met text... beginnend met: Your web server does not appear to support any common database types. Check with your hosting provider to see if they offer any databases that Drupal supports.', array('@drupal-databases' => 'http://drupal.org/node/270#database')), ); } else { $form['basic_options'] = array( '#type' => 'fieldset', '#title' => st('Basic options'), '#description' => '
En daar stopt alles bij. Het is nu reeds vele uren dat ik hiermee bezig ben en mijn zenuwen staan uiteraard wel gespannen.
Wat kan jij me adviseren?

Thx voor de medewerking
marc.august@gmail.com

afbeelding van Xano
Door Xano op 21 juni, 2008 - 16:13

Ik weet wat het probleem is, maar ik verbaas me erover dat dit probleem zich voordoet. Wat is er namelijk aan de hand: PHP draait niet. Die code die je ziet is PHP en die hoor je niet te zien als PHP draait. Heeft Xampp geen control panel waarbij je PHP kan inschakelen?

Als ik later vandaag wat tijd heb zal ik proberen of ik even wat kan proberen op mijn laptop (Heb alleen daar Windows op staan), ik moet nu even een paar andere dingen doen.

Ga in ieder geval zelf even kijken of je een control panel kan vinden en loop daar de instellingen even door, misschien dat PHP daar gewoon echt uitgeschakeld staat.

Nederdev : webdesign en -development

My name is Bart - web & events
iDEAL, OmniKassa, en meer.

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.