Internal Server Error na uploaden Drupal

Ik heb Drupal 4.6.5 ge-upload naar mijn sub-domein http://php.supercarsnet.nl, maar als ik nu naar http://php.supercarsnet.nl/index.php ga, krijg ik de volgende foutmelding:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webadmin@lycos-europe.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Ik heb Lycos inmiddels al diverse e-mails gestuurd maar er komt geen reactie van hun kant. Heeft iemand misschien een idee wat ik verkeerd gedaan heb?

Auteur: 
user155
Door Dries op 23 februari, 2006 - 10:19

Dit kan betekenen dat het .htaccess-bestand dat je hebt geupload niet correct is of dat je via het .htaccess-bestand functionaliteit probeert te gebruiken die niet beschikbaar of toeganelijk is. Eventueel moet je dat bestand aanpassen of zelfs weghalen.

Door user155 op 23 februari, 2006 - 16:25

Nadat ik het .htaccess-bestand heb verwijderd, krijg ik een andere foutmelding:

Access denied for user: 'supercarsnet_nl@wmphpp09.st2.lyceu.net' (Using password: YES)

Ook nadat ik met Notepad zelf een nieuw .htaccess-bestand heb aangemaakt en dit bestand heb geupload, blijft mijn sub-domein bovenstaande foutmelding geven.

Door Heine op 23 februari, 2006 - 17:44

Je bent nu een stap verder. Drupal kan geen contact krijgen met je database.

Dat ligt waarschijnlijk aan je database url ($db_url in sites/default/settings.php). Controleer ook of je gebruikersnaam rechten heeft op de database. Bij veel hostingproviders moet je overigens 'localhost' gebruiken als database host.

Door user155 op 23 februari, 2006 - 21:13

Als ik naar deze url (http://php.supercarsnet.nl/sites/default/settings.php) ga, krijg ik een lege pagina te zien. Ik heb settings.php lokaal geopend met Notepad en dan staat er dit:

* Database URL format:
* $db_url = 'mysql://username:password@localhost/database';
* $db_url = 'pgsql://username:password@localhost/database';
*/
$db_url = 'mysql://username:password@localhost/database';
$db_prefix = '';

afbeelding van florisla
Door florisla op 15 maart, 2006 - 11:24

De regel $db_url = '...'; moet je ook echt invullen!
Zie puntje 4 op http://drupal.org/node/260

je hebt nodig: username en paswoord van je database, en de hostname van mysql (hoogstwaarschijnlijk 'localhost').

Hopelijk heb je de drupal database al aangemaakt, anders ben je er nog niet hoor...

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee