afbeelding van guus.v.d.vlugt

Local Site Drupal 9 Onjuiste PhP-versie

Hallo,

Heb op mijn D-schijf XAMPP geïnstalleerd en Drupal 9.2.4 in /XAMPP/htdocs uitgepakt
Bij de installatie van Drupal krijg ik de volgende melding:
"Uitgeschakeld
Drupal vereist dat u de PHP-extensies uit de volgende lijst activeert (kijk op de pagina met systeemvereisten voor meer informatie):"

terwijl in het scherm de PHP versie 8.0.9 wordt aangegeven. (Afbeelding 1)

In een ander forumonderwerp werd aangegeven dat er in XAMPP/PHP/PHP.INI de juiste PHP versie kon worden ingeschakeld, maar kon dit nergens vinden. (Afbeelding 2)

In D:\xampp\htdocs\drupal\core\composer.json staat "php": ">=7.3.0",
Dat zou dus moeten kloppen. Heb ergens gelezen dat er meerdere php.ini's zijn die mogelijk roet in het eten gooien.

Geen idee hoe ik dat kan verhelpen, wie wel?

Groeten,

Guus van der Vlugt

BijlageGrootte
Image icon Knipsel.JPG43.66 KB
Image icon Knipsel2.JPG47.97 KB
Drupalversie: 
9.x
Auteur: 
guus.v.d.vlugt
Door guus.v.d.vlugt@... op 24 augustus, 2021 - 18:45

Typfouten verbeterd.

Guus van der Vlugt

afbeelding van jo.w
Door jo.w op 25 augustus, 2021 - 04:25

Het is al een hele tijd geleden dat ik Xampp gebruikte, ik werk tegenwoordig rechtstreeks op de server en daar kan ik bij de instellingen van php bij via een controle panel.

Op je eerste afbeelding een foutmelding en een aanbeveling en beide kan ik aanpassen via dat controle panel.
gd is een extensie om afbeeldingen te verwerken en die moet je inschakelen. Is die niet geïnstalleerd dan zal je dat zelf moeten doen. Als ik google op "php extension gd" kom ik al direct heel wat oplossingen tegen.

De aanbeveling, OPcache in te schakelen, is om de snelheid van je site te verbeteren. Ook hier dus inschakelen en eventueel eerst installeren.

Ik moet maar vinkjes zetten. Heeft dus niets met je php-versie te maken.

BTW, pas je gebruiksnaam eens aan, nu is je email voor iedereen zichtbaar.

Jo

afbeelding van guus.v.d.vlugt
Door guus.v.d.vlugt op 25 augustus, 2021 - 15:57

Na wat aanpassingen in php.ini werkt alles. Bedankt.

Guus

Guus van der Vlugt

afbeelding van Jurgen M
Door Jurgen M op 27 augustus, 2021 - 10:09

Drupal ondersteunt ook nog niet volledig php 8. Aangeraden is php 7.4

afbeelding van guus.v.d.vlugt
Door guus.v.d.vlugt op 27 augustus, 2021 - 17:09

Heb ik geïnstalleerd en werkt.
Bedankt.

Guus van der Vlugt

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee