Van local naar host

Hallo,

ik heb mijn local ontwikkelde site overgezet naar de host. Ik krijg (via de URL) mijn eerste pagina in beeld. Echter ik kan de tabbladen en niet openen.
De URL van het tabblad verwijst naar de local site; http://localhost/drupal/user/password. Idem die van : http://localhost/drupal/contact. Terwijl de andere tabbladen naar een node verwijzen. ALs voorbeeld: URL/node/80.

Wie kan mij op weg helpen?

Met groet,

WIllem-Jan

Drupalversie: 
7.x
Auteur: 
Lawx
afbeelding van chlee
Door chlee op 24 oktober, 2012 - 19:06

Tip
Check je settings.php bestand in je drupal site.

Door Lawx op 25 oktober, 2012 - 14:50

Hi Chlee,

dat heb ik al gedaan en volgens mij is het goed:
$databases = array (
'default' =>
array (
'default' =>
array (
'database' => 'database naam op host',
'username' => 'username behorende bij die database naam',
'password' => 'password idem',
'host' => 'localhost',
'port' => '',
'driver' => 'mysql',
'prefix' => '',
),
),
);
Als dit niet goed is / zou zijn, dan krijg ik toch ook niet mijn homepage met tabbladen als ik de URL oproep?

Nog ideeën?

Willem-Jan

afbeelding van florisla
Door florisla op 30 oktober, 2012 - 14:09

Je moet niet enkel de $databases variabele controleren in settings.php ...

Door Lawx op 31 oktober, 2012 - 10:16

Hi Florisla,

....wat dan nog meer.

WJ

afbeelding van florisla
Door florisla op 7 november, 2012 - 11:26

'Alles eens overlopen' is altijd een goed idee natuurlijk bij een settings bestand.

Maar in dit geval lijkt het me nuttig om $base_url aan te passen.

afbeelding van be-web
Door be-web op 7 november, 2012 - 15:59

Heb je de cache-tabellen geleegd van je database? Misschien houdt die nog je lokale paden vast.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door Lawx op 8 november, 2012 - 14:44

Dag be-web,

dat had ik gedaan. Nu eerst maar eens kijken naar $base_url. En anders maak ik local een heel nieuwe installatie van Xampp en Drupal.

WJ

Door NixBox op 9 november, 2012 - 11:36

Volgens mij heb je clean urls niet uitgezet tijdens het backuppen van je site...

probeer eens je pagina te benaderen via /?=node/... <- Node ID

Mocht dat wel lukken ...makkelijkste is dan clean urls uit te zetten en opnieuw een database backup te maken en deze op de nieuwe server plaatsen.

Gr. NixBox

afbeelding van be-web
Door be-web op 9 november, 2012 - 11:59

Waarom zou dat effect kunnen hebben? Clean urls slaat alleen relatieve paden op, relatief aan $base_url.

-----
Met vriendelijke groet,
Hans Kuiters
BE-WEB

Door NixBox op 9 november, 2012 - 23:58

Vreemd.. heb exact hetzelfde probleem gehad... Wanneer ik dus clean urls niet had uitgezet. Toen heb ik clean URLS uitgezet en opnieuw een backup gemaakt van de database en deze over gezet naar een andere server. Dat loste toen bij mij het probleem op. Mag je mij vertellen waarom dit toen wel werkte :)

afbeelding van jo.w
Door jo.w op 9 november, 2012 - 14:16

Ik zet nooit clean urls uit bij het backuppen of updaten. Geen enkele module trouwens.

Jo

Bookmark and Share

Drupal is een geregistreerd merk van Dries Buytaert. | Powered by Pantheon.

Drupal.be/Drupal.nl is de website van de Nederlandstalige Drupalgemeenschap.

onomatopee